[HELP NEEDED] Digitizer power-up problem

Hi guys,

I used search, but couldnt find anything similour to my problem. Hope someone can help me out.

Regarding:
I got a Tronsmart PS7 MTK6592 (7 inch dual sim octa) phablet for 4 months and it is absolutely a great device, but it turns me down sinds several weeks and is driving me nuts... cant find a solution on the internet or on XDA forum
The phablet has never been flashed with another rom.. i did flash Root and CWM, but that was never an issue for 4 months.

Problem:
The screen responce: it just wont respond to my touch.
When i use the powerbutton several times on/off, the screen starts to react to my touch and i can use the phablet fully.
When i power-up my device everything works, sound, LCD, ledflash and hardwarebuttons, but not the screentouch. The only option is to pull the battery and start all over again booting the phone, hoping the digitizer will respond. Sometimes it does, mostly it doesn't.

What have i done myself to make it work:

  • When i restart the device with power+volumedown i get the debug engeneer factory test. when i use the lcd screen test, it works flawlessly, even when i try it for several times, the screen touch response allway works.
  • When booted, I tried the MTK engineer mode *#*#3646633#*#* but this screentest is useles, because when the touchscreen works, it just works...
  • Flashing stock rom for 11 times... wiping cache and dalvic for 5 times without exiting recovery etc on every flash, nothing works.
  • When i restore my backup with CWM, the device just works as it should, but the touchscreen problem still persists.
  • Just restoring data or system, nothing worked... the device works, but the problem still persists.
  • I openend the device to check if some connector is loose, but everything was just fine. I just pushed the connectors some more just in case, but it wasnt a solution.

Chinese supplier help:
I had email exchange with the supplier of this phablet, but the only thing they could think of is flashing a stock ROM and do all the standard clear cache and wipe dalvic solution, so that wasnt much help.
they offered me to send back the phablet to them, but they are not clear about warrenty etc. so when my device is in China, they could basicly charge me with anything they want... and i dont want be in that position.

My own conclusion:
As i have mentioned before, the screen begins to work when using the powerbutton on/off for 10 times, so basicly the device is allright, just the digitizer (touchresponce) isnt been powered up i think... or something in that direction. If the digitizer was broken, it wouldnt work at all i guess, so it has to be something like that..

Question 1:
Who can help me out with this one...
Does anyone have experienced my problem with his/her (MTK) phone and if yes, did you find a solution?

Question 2:
Is there a script or buildprob. / int.d value that i can set to mandatory push/activate the digitizer?

Thank you in advance,


Regards,

Axelman

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by allison23
3 hours ago
Last post by nathen61
3 hours ago
Last post by jerald.walter
2 hours ago
Last post by katelynn.robel
2 hours ago
Last post by jacobi.mona
2 hours ago
Last post by nelson.huel
4 hours ago
Last post by cole.kelsi
3 hours ago
Last post by nolan.altenwerth
3 hours ago